软件说明

江苏沁恒股份有限公司

 http://wch.cn

软件说明

本驱动只支持WCH品牌PCI接口转串/并口芯片CH35X，请认准芯片上WCH字样！

PUMPSETUP.EXE用于安装PCI卡驱动，以及修改串并口号。
驱动支持：
DOS/NT40/98/ME/2K/XP/VISTA/WIN 7/SERVER 2003/2008/WIN 8/WIN 8.1。
DOS驱动及LINUX驱动，需进入相应的目录，运行指定的安装及卸载程序。

驱动安装方法：

  1. 先将板卡插入电脑PCI插槽内；
  2. 选择卡的类型；
  3. 点击<安装驱动>按钮进行驱动安装或点击<卸载驱动>按钮进行驱动卸载。
  • 如果提示<无设备驱动可装>，表示没有找到卡，请检查PCI卡是否已插入PCI插槽内或没插好
  • 如果确实已插入板卡，检查PCI卡是否已插紧，以及PCI金手指或插槽内有异物，导致卡接触不好，也可以换一个插槽试试。
  • 如果上述检查后仍出此情况，点击<遇到问题请点击>，运行<查看设备列表>程序，搜索"有问题的PCI设备"，查看是否存在一个未装驱动的PCI卡。
  • 驱动装好后，如需调整串并口号，可以点击<遇到问题请点击>按钮，运行<修改串并口号>程序进行调整，支持多串口号同时调整。

目录

Copyright (c) 2014 wch.cn All Rights Reserved


目录

目录

常见安装/使用问题解答

1 -- 驱动下载

2 -- 驱动安装

3 -- 驱动卸载

4 -- 查看设备ID

5 -- 修改串/并口号

6 -- 测试CH353定址成功

联系我们


常见安装/使用问题

常见安装/使用问题

在板卡出现问题时请对照以下常见安装/使用问题逐条确认下，问题还未解决的话，
可以把出现的现象及使用环境等详细的信息发送到技术支持信箱tech@wch.cn或者
tech@winchiphead.com中，我们将尽快答复。

Q1：板卡插到计算机上，发现新硬件了，但安装程序提示“无设备驱动可装”？
A1：1、请确认板卡上的PCI芯片是否为CH35X系列芯片：
-- 可以关机拔下板卡查看板卡主芯片是否有“CH352L”等CH35X字样。
-- 也可以看设备管理器，双击找到的新硬件，打开属性界面查看“详细信息”
中的“设备硬件ID”，看是否为“PCI\VEN_4348&...”或“PCI\VEN_1C00&...”
如果VEN 不是4348或1C00，芯片上又没有“CH351Q”等CH35X字样，
说明此卡主芯片不是本公司产品，不适用于该驱动，请和板卡销售商家联系。
 2、如是CH35X 板卡, 请做下列尝试来确认板卡是否能正常工作：
用橡皮擦擦拭下PCI卡的金手指表面，或将板卡拔掉重插，或换一个PCI插槽，
或换一台机器重试。

Q2：在网站上为什么找不到CH350/CH351/CH352/CH353对应的驱动？
A2：CH35系列芯片驱动全部放在CH35xDrv.zip驱动包内（x=0/1/2/3…），
内有驱动安装程序PUMPSETUP.EXE，打开软件后先选择卡的类型（可默认识别安装），
然后点击“安装驱动”按钮进行驱动安装，点击“卸载驱动”按钮进行驱动卸载。
驱动包内已对板卡驱动进行了分类，驱动支持DOS/ Windows NT4.0/98/2000/ME/
XP/ VISTA/WIN 7/WIN 8/WIN 8.1/Server 2003/2008/32/64-bit, Linux 以及DOS 系统，
驱动目录分类说明请见驱动包内的readme.txt文档。
具体驱动下载安装方法请见驱动下载、驱动安装等。

Q3：怎么判断板卡驱动已装好?
A3：驱动安装成功后，查看设备管理器，会在“多功能卡”中看到CH35X 设备，
以及在“端口(COM和LPT)”中看到PCI_PARALLEL 或PCI_SERIAL 设备。

Q4：板卡插到计算机上，系统没提示发现新硬件？
A4：请确认PCI卡的金手指表面清洁，如不清洁可将橡皮擦一下；
或将板卡拔掉重插，或换一个PCI插槽，或换一台机器重试。

Q5：板卡为1并/1串卡，程序自动识别安装的驱动多了一个串口/并口？
A5：由于1并卡/1串卡/1并1串卡的硬件ID是相同的，如果采用自动识别安装，
只能采用1并1串卡的通用驱动来安装。板卡为1并卡或1串卡时，请选择
卡的类型安装，或指定驱动路径安装。

Q6：驱动提示安装成功，设备管理器能看到串/并口，但上面有黄色感叹号？
A6：查看“设备管理器”-->“端口(COM和LPT)” --> PCI_PARALLEL 或PCI_SERIAL
设备属性页面内的“设备状态”提示，
正常工作时应显示为：“这个设备运转正常”等；
如出现“设备无法启动”显示，
请将板卡拔掉重插／换一个PCI插槽／换一台机器重试；
如出现“无法加载设备驱动”等类似提示，尝试以下方法：
1、请将驱动卸载后，重启再重新安装一下；
2、确认串/并口是否已被使用，如被占用，可以使用“修改串并口号”的工具
来修改COM口/LPT口号（参考修改串/并口号），或在设备管理器内修改
有必要的话，修改成功后重启一下机器。

Q7：并口连上打印机／加密狗／仿真器，打印机／加密狗／仿真软件无法工作？
A7：无法工作时，请先确认软件是否有设置并口号或并口地址的地方，
如有，请按照CH35x 转出来的并口号（一般为LPT3）设置一下。
如没有，那可能是PC软件对并口的号或者地址有要求，
导致PC软件找不到PCI所扩展的并口，可尝试：
1、点击 PUMPSETUP.exe 的“修改串并口号” 按钮来运行ModifyCOM&LPTName V1.10，
将并口号更改为LPT1或LPT2（参考修改串/并口号）；
2、如还是不行，可选择CH353芯片扩展的并口，在R21处增加一个33欧姆的电阻，
使其支持378/278地址；
3、有可能PC软件对并口模式有要求（是否要求为EPP或ECP模式的并口？）
如果是：请参照“Q8：怎么将并口驱动更新为 DRV_ExParaPort内的驱动?”
的问题解答更新一下驱动。

Q8：怎么将并口驱动更新为DRV_ExParaPort内的驱动?
A8：安装方法同CH35xDrv.zip，可以使用DRV_ExParaPort下的setup.exe程序直接进行驱动
更新；或者在设备管理器内先将PCI_LPT设备驱动卸载掉，然后扫描检测硬件，
系统提示发现新硬件后将驱动路径指到 DRV_ExParaPort目录进行安装。

Q9：什么是CH353的定址功能？
A9：CH353芯片通过特殊技术可以同时支持系统分配的PCI地址和并口传统
地址0x378H或者0x278H，启用CH353定址功能需要加焊R21（33欧姆）电阻。

Q10：如何修改CH353定址地址？
A10：CH353板卡焊接上R21就默认定址到0x378H，如果需要定址到0x278H，可以加个
EEPROM（如24C01），在24CXX中使用编程器烧入“278地址.hex”文件，或者用
CH35xCFG.exe 按照说明修改。

Q11：如何确定CH353是否定址成功？
A11：由于不管是否采用定址，在设备管理器中看到的CH353 板卡地址都是4位数的PCI
地址，所以要确定是否定址成功，需要用CH35xCFG.exe工具，点击
“检测卡”-->“测试定址成功”如定址成功会出现“并口0x378地址可用”提示框，
如图示。


1、驱动下载

1、驱动下载

登陆江苏沁恒股份有限公司网站 http://wch.cn ，从在线下载中

http://wch.cn/downloads.php?name=pro&proid=168 下载CH35x驱动CH35XDRV.EXE


2、驱动安装

2、驱动安装

1 -- Windows 下安装 2种方式任选1种 <以CH352 1串1并卡为例 >

  • 用PUMPSETUP.EXE 自动安装
  • 手动指定位置安装置
    •

    2 -- Linux 下安装 <以CH352 2串卡为例 >

    请参考相对应文件夹下的README文档，以PCI转2串口为例，
    安装：
    1 -- 在ROOT 目录下创建一个目录，如/temp
    2 -- 输入命令行
    # cd /
    # mkdir temp
    3 -- 得到驱动文件"wch_vx.x.x.x.tar.gz"后复制到/temp目录，
    解压安装，输入命令行
    # cp wch_vx.x.x.x.tar.gz /temp
    # cd /temp
    # tar xvfz wch_vx.x.x.x.tar.gz
    # cd /temp/wch
    # make clean ; make install
    加载驱动模块，输入命令行
    # modprobe wch
    或者 # insmod /temp/wch/driver/wch.ko (kernel 2.4下用wch.o)
    校验驱动模块:
    1-- 输入命令行
    # lsmod | grep wch
    卸载驱动：
    1-- 输入命令行
    # rmmod wch

    3 -- DOS 下安装

    请参考相对应文件夹下的README文档，
    安装：
    输入"CH35XDOS -a" ,按回车,把CH35XDOS端口安装到系统,显示如下:
    COM1 exists at 3FB
    COM2 exists at 2FB
    COM3 added at 9000 (IRQ9)
    COM4 added at 9400 (IRQ9)
    LPT1 exists at 378
    LPT2 added at 9800 (IRQ9)
    如果想每次重启时安装，请在AUTOEXEC.BAT中添加一行:
    CH35XDOS -a -s(或者CH35XDOS -a -r -s)


自动安装

自动安装

关机à插入CH35x卡à开机进系统à运行PUMPSETUP.EXE à

可以采用默认的“自动识别卡” 或 下拉列表选择对应的CH35x板卡类型à"安装驱动"

安装过程中出现这个提示不用理睬，系统反应和驱动安装进程不同步而已，

驱动正在正常安装。

驱动安装成功

安装完成，设备管理器出现COM/LPT口。


手动安装

手动安装

关机à插入CH35x卡à开机进系统à发现新硬件à指定驱动位置文件à安装

安装完成，设备管理器出现COM/LPT口。


3、驱动卸载

3、驱动卸载

运行 PUMPSETUP.exe à 可以采用默认的“自动识别卡” 或 下拉列表选择对应要卸载的的CH35x板卡类型à"卸载驱动"


4、查看设备ID

4、查看设备ID

运行 PUMPSETUP.exe à点击“遇到问题请点击”按钮à点击“查看设备列表” 选择 “所有PCI 设备” 找到相应硬件后，查看硬件ID即可。

该功能可用于驱动安装异常时检查硬件是否正常、系统是否找到硬件等。


5、修改串/并口号

5、修改串/并口号

< 以CH352 1串1并定址卡为例 >

  • 【Windows 2000/XP及以上系统】
  • 【Windows 98系统】
    •


【Windows 2000/XP/VISTA系统下】

【Windows 2000/XP/VISTA系统下】

运行 PUMPSETUP.exe à点击“遇到问题请点击”按钮à点击“修改串并口号” 按钮，检测到CH35X 的串并口后，

指定需要改动的COM口和LPT口号。

修改并口LPT 口号：

修改串口COM 口号：（支持多个串口同时修改）

修改成功显示，有些机型需要重启才显示设置成功。


【Windows 98系统下】

【Windows 98系统下】

Windows 98 下设备管理器看不到串口号，修改串口号需要用注册表。


6、测试CH353定址成功

6、测试CH353定址成功

用CH35xCFG.exe工具，如图示点击“检测卡”à“测试定址成功”，

如定址成功会出现“并口0x378地址可用”提示框。

如果“测试定址成功”按键为灰色不可用，说明板卡不是CH353定址卡。

如果定址未成功会出现“并口0x378地址不可用”提示框，麻烦您将主板型号发到

技术支持信箱tech@wch.cn或者tech@winchiphead.com中。


联系我们

联系我们

技术支持邮箱：tech@wch.cn或者tech@winchiphead.com