目录

南京沁恒电子有限公司

 http://wch.cn

目录

1 -- 驱动下载

2 -- 驱动安装

3 -- 驱动卸载

4 -- 查看设备ID

5 -- 修改串/并口号

6 -- 测试CH353定址成功

常见安装/使用问题解答

联系我们

Copyright (C) 2009 wch.cn All Rights Reserved


1、驱动下载

1、驱动下载

登陆南京沁恒电子有限公司网站 http://www.wch.cn ，从在线下载中

http://www.wch.cn/download/list.asp?id=112 下载CH35x驱动CH35XDRV.ZIP


2、驱动安装

2、驱动安装

< 以CH352 1串1并卡为例 >

（2种方式任选1种）

  • 自动安装
  • 手动安装
    •


1）自动安装

1）自动安装

关机à插入CH35x卡à开机进系统à运行PCISETUP.EXE àSELECT PCI CARD 选择

CH35x卡的类型àINSTALL

安装过程中出现这个提示不用理睬，系统反应和驱动安装进程不同步而已，

驱动正在正常安装。

驱动安装成功


2）手动安装

2）手动安装

关机à插入CH35x卡à开机进系统à发现新硬件à指定驱动位置文件à安装

安装完成，设备管理器出现COM/LPT口。


3、驱动卸载

3、驱动卸载

< 以CH352 1串1并卡为例 >

（2种方式任选1种）

  • 用PCISETUP.EXE 卸载
  • 用设备管理器卸载
    •


1）用PCISETUP.EXE 卸载

1）用PCISETUP.EXE 卸载

运行 PCISETUP.EXE，点击 UNSTALL 卸载


2）用设备管理器卸载

2）用设备管理器卸载

右键单击"CH352 PCI=>SERIAL&&PARALLEL" 选择“卸载”

或者双击"CH352 PCI=>SERIAL&&PARALLEL"或右键单击选择“属性”，点击卸载。


4、查看设备ID

4、查看设备ID

< 以CH352 1串1并卡为例 >

右键单击 “我的电脑” à“属性”à “硬件”à“设备管理器”


1）未装驱动时

1）未装驱动时

双击“PCI串行口”或右键单击选择“属性” 。


2）驱动安装成功时

2）驱动安装成功时

双击“CH352 PCI=>SERIAL&&PARALLEL”或右键单击选择“属性”，


5、修改串/并口号

5、修改串/并口号

< 以CH353 2串1并定址卡为例 >

  • 【Windows 2000/XP/VISTA系统下】
  • 【Windows 98系统下】
    •


【Windows 2000/XP/VISTA系统下】

【Windows 2000/XP/VISTA系统下】

板卡安装成功后，会在设备管理器中出现 PCI_COM 和 PCI_LPT 以及多功能卡

的标识,一般CH35x 默认的COM口号从COM3分配起，LPT口号为LPT3。

将COM3改为COM1，LPT3为LPT1，可以用TOOLS文件夹中的ModifyCOMLPT.exe

工具来修改，也可从设备管理器中手动修改。有些机器可能需要重启才设置成功。


1）用ModifyCOMLPT.exe 工具串/并口号

1）用ModifyCOMLPT.exe 工具串/并口号

运行TOOLS文件夹中的 ModifyCOMLPT.exe ，检测到CH35X的串并口后，指定需要改动的COM口和LPT口号，

同样来修改另1个串口COM4

修改成功显示，有些机型需要重启才显示设置成功。

如果COM口号已被占用，用设置串口号状态工具来改变状态。

设置成功


2）从设备管理器修改串/并口号

2）从设备管理器修改串/并口号

修改串口号

修改并口号


【Windows 98系统下】

【Windows 98系统下】

Windows 98 下设备管理器看不到串口号，修改串口号需要用注册表。


6、测试CH353定址成功

6、测试CH353定址成功

用TOOLS中提供的CH35xCFG.exe工具，如图示点击“检测卡”à“测试定址成功”，

如定址成功会出现“并口0x378地址可用”提示框。

如果“测试定址成功”按键为灰色不可用，说明板卡不是CH353定址卡。

如果定址未成功会出现“并口0x378地址不可用”提示框，麻烦您将主板型号发到

技术支持信箱tech@wch.cn或者tech@winchiphead.com中。


常见安装/使用问题

常见安装/使用问题

在板卡出现问题时请对照以下常见安装/使用问题逐条确认下，问题还未解决的话，

可以把出现的现象及使用环境等详细的信息发送到技术支持信箱tech@wch.cn或者

tech@winchiphead.com 中，我们将尽快答复。

Q1：在网站上为什么找不到CH350/CH351/CH352/CH353对应的驱动？

A1：CH35系列芯片驱动全部放在CH35xDrv.zip驱动包内（x=0/1/2/3…）

内有驱动安装程序PCISETUP.EXE，打开软件后先选择卡的类型

（S为串口，P为并口），然后选择“INSTALL”按钮进行驱动安装，

点击“UNINSTALL”按钮进行驱动卸载。

驱动包内已对板卡驱动进行了分类，驱动支持DOS/

Windows NT4.0/98/2000/ME/XP/ 2003/VISTA/WIN 7 32/64-bit

以及 Linux 系统，驱动目录分类说明请见驱动包内的readme.txt文档。

具体驱动下载安装方法请见驱动下载、驱动安装等。

Q2：驱动包内都有什么配套软件？

A2：ModifyCOMLPT.exe用于修改CH35系列板卡所扩展的串口号或并口号。

CH35xCFG.exe用于配置CH353芯片所做板卡上配置芯片内容。

CH35xDrv驱动网上下载链接为 http://www.wch.cn/download/list.asp?id=112。

Q3：怎么判断板卡驱动已装好?

A3：驱动安装成功后，会在“设备管理器”à“端口(COM和LPT)”

内看到PCI_LPT和 PCI_COM设备。可参考图

Q4：板卡插到计算机上，没发现提示发现新硬件；或发现新硬件了，

但安装过程中提示找不到匹配的硬件驱动？

A4：1、首先确认板卡上的PCI芯片是否为CH35X系列芯片；

2、如是, 请做下列尝试来确认板卡是否能正常工作：

确认PCI卡的金手指表面清洁，如不清洁可将橡皮擦一下；

将板卡拔掉重插／换一个PCI插槽／换一台机器重试。

Q5：驱动提示安装成功，设备管理器能看到串/并口，但上面有黄色感叹号？

A5：查看“设备管理器”à“端口(COM和LPT)” à PCI_COM或PCI_LPT

设备属性页面内的“设备状态”提示，

正常工作时应显示为：“这个设备运转正常”等；

如出现“设备无法启动”显示，

请将板卡拔掉重插／换一个PCI插槽／换一台机器重试；

如出现“无法加载设备驱动”等类似提示，尝试以下方法：

1、请将驱动卸载后，重启再重新安装一下；

2、确认串/并口是否已被使用，如被占用，可以使用TOOLS文件夹中的

ModifyCOMLPT.exe 工具来修改COM口/LPT口号

或在设备管理器内修改（参考修改串/并口号），修改成功后重启一下机器。

Q6：并口连上加密狗/仿真器后，加密狗／仿真软件无法工作？

A6：无法工作时，请先确认软件是否有设置并口号或并口地址的地方，

如有，请按照CH35x 转出来的并口号（一般为LPT3）设置一下。

如没有，那可能是PC软件对并口的号或者地址有要求，

导致PC软件找不到PCI所扩展的并口，可尝试：

1、用ModifyCOMLPT.EXE软件将并口号更改为LPT1或LPT2

（参考修改串/并口号）；

2、如还是不行，可选择CH353芯片扩展的并口，在R21处增加一个33欧姆的电阻，

使其支持378/278地址；

3、有可能PC软件对并口模式有要求（是否要求为EPP或ECP模式的并口？）

如果是：请参照“Q7：怎么将并口驱动更新为 DRV_ExParaPort 内的驱动?”

问题解答更新一下驱动。

Q7：怎么将并口驱动更新为DRV_ExParaPort内的驱动?

A7：安装方法同CH35xDrv.zip，可以使用DRV_ExParaPort下的setup.exe程序

直接进行驱动更新；或者在设备管理器内先将PCI_LPT设备驱动卸载

掉，然后扫描检测硬件，系统提示发现新硬件后将驱动路径指到

DRV_ExParaPort目录进行安装。

Q8：如果下载软件只支持378的并口，我用得是CH350/ CH351/CH352怎么办？

A8：CH350/ CH351/CH352 都不支持定址到 0x378H，只有CH353支持。

Q9：什么是CH353的定址功能？

A9：CH353芯片通过特殊技术可以同时支持系统分配的PCI地址和并口传统

地址0x378H或者0x278H。

Q10：如何修改CH353定址地址？

A10：CH353板卡焊接上R21就默认定址到0x378H，如果需要定址到0x278H，

可以加个 EEPROM（如 24C01），在24CXX中使用编程器烧入

“278地址.hex”文件，或者用 CH35xCFG.exe 按照说明修改。

Q11：如何确定CH353是否定址成功？

A11：用TOOLS中的CH35xCFG.exe工具，点击“检测卡”à“测试定址

成功”，如定址成功会出现“并口0x378地址可用”提示框，如图示。

Q12：怎么区分要安装的设备接口是串口还是并口？

A12：串口的接口一般为9针，并口一般为25/36针。

Q13：linux中如何安装ch35x驱动

A13：请参考相对应文件夹下的README文档，以PCI转2串口为例，

安装：

1 -- 复制 ch35x_80x86.o 到 /usr/sbin

2 -- 加载 /usr/sbin/ch35x_80x86 到 /etc/rc.d/rc.local 的末尾

3 -- 重启

如果安装了2串卡，ttyS2 和 ttyS3 就可以使用了

卸载：

1 -- 删除 在 /etc/rc.d/rc.local 末端的 /usr/sbin/ch35x_80x86

2 -- 删除 /usr/sbin/ch35x_80x86.o


联系我们

联系我们

技术支持电话：025-52638365，52638363，52638362

技术支持邮箱：tech@wch.cn或者tech@winchiphead.com


PCI板卡驱动安装及问题解答

在板卡出现问题时请对照【常见安装/使用问题】逐条确认下，问题还未解决的话，可以把出现的现象及使用环境等详细的信息发送到技术支持信箱tech@wch.cn或者tech@winchiphead.com中


驱动安装图解

< 以Windows XP系统，CH352 转1串口1并口卡为例 >